jboss « Map « JPA Q&A

1. hibernate fail mapping two tables    stackoverflow.com

I'd like to understand how it is possible: Until I was working with one table everything worked fine, when I have mapped another table it fails as shown below: Glassfish start INFO: configuring from resource: ...

2. How to Map a Table with localized Product Names using JPA?    stackoverflow.com

I have an entity product:

@OneToMany(cascade = CascadeType.ALL, fetch = FetchType.LAZY, mappedBy = "product")
public Map<String,ProductNames> getProductNames() {
    return this.productNames;
and an entity named productNames which contains the localized versions of ...

3. JPA excesive querys for mapping an entity    stackoverflow.com

I have the following entity:

    @Table(name = "srht_estructuras_organicas")
    public class EstructuraOrganica extends EntidadBasica implements Auditable,

4. Hibernate TABLE is not mapped    stackoverflow.com

I receive this error

11:55:43,125 INFO  [org.hibernate.impl.SessionFactoryObjectFactory] (MSC service thread 1-16) Not binding factory to JNDI, no JNDI name configured
11:55:43,215 ERROR [stderr] (MSC service thread 1-16) org.hibernate.hql.ast.QuerySyntaxException: ServerSettings is not ...

5. Mapping Exception at runtime-Jboss EAP 4.0.3-Hibernate 3.0.5    forum.hibernate.org

I have come across an in issue in our production server. I am using a named query to get some session details and out of 100 times 1 or 2 fails. Pls find the exception below. I have no idea why this error is coming when it working all the other times in the same method. I am using JBoss EAP ...

6. Dialect mapping error in using Oracle XMLType on JBoss    forum.hibernate.org

Author Message invincible_virus Post subject: Dialect mapping error in using Oracle XMLType on JBoss Posted: Tue Oct 11, 2011 10:50 am Newbie Joined: Tue Oct 11, 2011 10:37 am Posts: 3 I want to use a Oracle XMLType column in my Entity Bean. I followed "http://community.jboss.org/wiki/MappingOracleXmlTypeToDocument" article which teaches to create a custom OracleXmlType class and use it as ...

7. Probelms with Mapping-file and JBoss    forum.hibernate.org

Hi, I'm using JBoss 3.0.3 with Hibernate 2.1beta3 and Struts 1.1. While deploying my project as a SAR-file, I get the following error: 2003-09-12 01:38:08,206 INFO [net.sf.hibernate.cfg.Configuration] Mapping resource: WEB-INF/classes/de/sam/strutstest/dto/mappings/User.hbm.xml 2003-09-12 01:38:08,237 ERROR [net.sf.hibernate.cfg.Configuration] Could not compile the mapping document java.lang.ClassNotFoundException: de.sam.strutstest.dto.User But the WAR-file inside includes the class de.sam.strutstest.dto.User in strutstest.war/WEB-INF/classes/de/sam/strutstest/dto (the mapping file is in path strutstest.war/WEB-INF/classes/de/sam/strutstest/dto/mappings). Sorry, if ...

8. JBoss unable to locate mapping xml files    forum.hibernate.org

Hello, I have been banging my head against a problem that seems to be a JBoss -Hibernate class loader problem for a couple days now. (Note, for reason I don't care to go into, I can not use the JBoss MBean configuration option.) I am trying to configure my hibernate session factory in the following way: Configuration cfg = new Configuration().addClass(PurchaseOrderImpl.class); ...

10. decentral registration of xml-mappings in jboss    forum.hibernate.org

Hello! I'm using jboss 3.2.2 with hibernate 2.1. All the documentation I found told me, the use of hibernate within jboss works like this: I register the hibernate service by creating a directory (e.g. "hibernate.sar") in the deploy-directory of my jboss server and put some config files into it. Well, this was no problem and I got a little test project ...

11. XML mapping won't compile on JBoss    forum.hibernate.org

So look your error.... In your mapping file you have your package path for the class isnt'it? And in your jboss-service.xml you have your package path more your directory classes/. That's why during the mapping you can't find your classes... beacause you declare your package like com.toto.tata.XXX.class and you ask for classes.com.toto.tata.XXX.class.

12. mapping exception while deploying hibernate3 in jboss-4.0.2    forum.hibernate.org

Newbie Joined: Thu Nov 23, 2006 6:21 am Posts: 2 I am getting following exception during deployment when i run the hibernate application application in jboss-4.0.2 15:43:05,327 INFO [DLQ] Bound to JNDI name: queue/DLQ 15:43:05,531 INFO [ConnectionFactoryBindingService] Bound connection factory for resource adapter for ConnectionManager 'jboss.jca:name=JmsXA,service=ConnectionFactoryBinding to JNDI name 'java:JmsXA' 15:43:05,718 INFO [WrapperDataSourceService] Bound connection factory for resource adapter for ConnectionManager ...

13. Hibernate and Jboss integration - Mapping Exception    forum.hibernate.org

I am using Hibernate Core 3.2.2 with Jboss Application Server 4.0.5GA. I managed to map my entities using myEntity.hbm.xml file for each. However, now I would like to use Hibernate Annotations to facilitate mapping especially when having attribute ovverrides in an embeddable class. I have replaced the myEntity.hbm.xml files with hibernate.cfg.xml file which includes a list of mapping classes as follows. ...

14. mapping problem with Hibernate 3.2 and jboss 4.2.0    forum.hibernate.org

Newbie Joined: Thu May 31, 2007 6:11 pm Posts: 1 I am trying to get a test jsf application to work on the standard jboss 4.2.0 AS server. I am using eclipse as the IDE. I set the build path in my eclipse project to point to jboss/default/lib jar files for hibernate and other required jars. when I deployed the application ...