Max « Oracle « JPA Q&A

1. C3P0 / Hibernate 3 / ORA-01000 Max Cursors

Hello friends - Hibernate 3.2./C3P0 .9/Oracle 10g OK. I have a low frequency, high volume operation; i.e., no data, no data, no data, several thousand rows of data. This has worked fine (at least within a context of c3po/Hibernate/Oracle connects) in the past when I got up to 2K records in one alert (i.e., per minute). Essentially I get an array ...

2. HQL max results and Oracle

I'm using Hibernate with Oracle EE I'm having a problem using the HQL and setMaxResults(). Here's the method to retrieve information from the database: Session hibernateSession = _hibernateSessionFactory.openSession(); List list = null; try { Query query = hibernateSession.createQuery("from Press as press where press.releaseDate < ? order by press.releaseDate desc"); query.setTimestamp(0, new Date(System.currentTimeMillis())); query.setMaxResults(maxResults); list = query.list(); } finally { hibernateSession.close(); ...

3. oracle/max open cursors and statement_cache.size

Hi, Running the JUnit tests that comes with Hibernate 2.1 I (using DBCP) always run into "java.sql.SQLException: ORA-01000: maximum open cursors exceeded" in the FooBarTest (and others). I have set hibernate.statement_cache.size=0 as the FAQ recommends and checked that the setting is indeed set when in the test's log file: 10:24:12,318 INFO Environment:466 - loaded properties from resource {hibernate.connection.password=test, hibernate.query.substitutions=true 1, ...

4. Oracle 10g and Double.MAX_VALUE

5. MAX function not working properly with oracle

ok i tried with the updated 2.1.8 library and still no luck. It looks pretty straight forward, but i must be doing something wrong. The thing i dont get is it shows the HQL in the log and the SQL its translated to just afterward, and it seems to just completely disregard and drop the "max" directive.... thnx