MappingException « Update « JPA Q&A

1. Error parsing the persistence.xml(org.hibernate.MappingException)

I am using JPA and I tried to put my configuration data in the persistence.xml file. But when I run the app, the error is as follows:

[hibernatetool] org.hibernate.MappingException: invalid configuration
[hibernatetool] org.xml.sax.SAXParseException: Document ...

2. MappingException: persistent class [...] not found

I'm having trouble setting up hibernate to work with my program. It's a stand-alone java application that accesses a postgresql database (previously through Torque, and I'm now trying to refactor it to use hibernate instead). I used the xdoclet hibernate task to create the .hbm.xml files, but when I try to generate the schema, it fails saying it can't find the ...

3. getting MappingException: persistent class [xxxx] not found

I am new to Hibernate. I have a small test program that tries to read data from database and display it. public class Test { public static void main(String[] args) throws Exception{ // configuration //Configuration cfg = new Configuration().addClass(AddressType.class); Configuration cfg = new Configuration().addResource("AddressType.hbm.xml"); SessionFactory sft = cfg.buildSessionFactory(); // open session Session session = sft.openSession(); // search query String search = ...

4. persisting object returns "MappingException: unknow ent

Here's the code that doesn't work: ApplExpertise myApplExpertise = new ApplExpertise(this.applId);; It crashes in I inserted a row manually and was able to update it. But for some reasons, it won't insert. Thx Hibernate version: version 3.0.5, 25 May 2005 Mapping documents: