jboss « Development « JSF Q&A

1. Does JBoss cache class files?    stackoverflow.com

I'm wrestling with a strange problem: When I make a change to a POJO or Seam Component in my localhost JBoss instance, restart it, and load the page, the change is ...

2. Which version of JBoss AS supports JEE6 (sepcially JSF2.0)    stackoverflow.com

Which version of JBoss AS supports JEE6 (sepcially JSF2.0)?

3. java.lang.illegalstatexception Application was not properly initialized    stackoverflow.com

I am getting the following error when deploying an application on JBoss 4.2.1

   7:05:59,673 ERROR [Application Name]StandardWrapper.Throwable
   java.lang.IllegalStateException: Application was not properly initialized at 

4. JSF 2.0: use Enum values for selectOneMenu    stackoverflow.com

I'm using JSF 2.0 and want to fill a selectOneMenu with the values of my Enum. A simple example:

// Sample Enum
public enum Gender {

  private final String ...

5. Are @ManagedBean's obsolete in JavaEE6 - because of @Named in CDI/Weld?    stackoverflow.com

Because of CDI (and its implementation Weld), every POJO in JEE6 can be annotated with @Named, which makes the POJO accessible to the view. Does that mean that ManagedBeans are completely ...

6. JSF 2.0 webdevelopment in Intellij 9 for JBoss 6    stackoverflow.com

I was wondering what would be the most practical approach to JSF 2.0 web development using IntelliJ 9, targetting JBoss 6. My project has a Maven Structure, though I would like to ...

7. CDI timeout results in an NPE    stackoverflow.com

Is there a way (in JSF 2) to catch a Conversation timeout and redirect a user to a new page? I'm getting nasty NullPointerExceptions when the conversation times out. I could ...

8. JSF FacesTagExtraInfo class not in JSF 1.2 v    stackoverflow.com

I'm trying to move and old JSF v1.0 application from Sun One to Jboss 4.3 EAP that has jsf v 1.2 jars. I've been able to get the application to ...

9. Using CDI instead of @ManagedBean: UnproxyableResolutionException because super class has no no-args constructor    stackoverflow.com

I'm trying to use CDI for my JSF/Java EE application. I have the following class hierarchy:

 * base controller class
 * also contains some final methods and an inner enum class ...

10. jsf-console 3.x on JBoss 6.x possible?    stackoverflow.com

I'm trying to move an application from JBoss 4.2.2 AS to 6.x AS. Right now I'm trying to get jbpm 3.x running on the AS I have this problem when trying ...

11. EJB3 JSF application run in jboss 5    stackoverflow.com

I am using JSF 1.2, EJB 3 on JBoss 5. This is my EJB:

public interface HelloServiceLocal {
    public void sayHello(String username);

public class HelloService implements HelloServiceLocal {

12. Help with JSF 1.2 + Jboss 5.1.0    stackoverflow.com

Hy all, I'm trying a simple project to work on jboss, but i'm stuck at this error (i already tried using .jsf on the URL). the application in tomcat ...

13. Is it possible to use flashvars with JBoss?    stackoverflow.com

I'm part of a team developing a product using JSF 2.0 and I was asked to investigate the possibility of including FusionCharts free in the app. I have tried different ways ...

14. Integrate Weld CDI into a JSF 1.2 EJB Application on jboss 6 AS    stackoverflow.com

since two evenings i am trying to integrate weld CDI into an EJB 3.1 Application with JSF 1.2. I simply tried to call a with @Named annotated controller in an JSF ...

15. Inject a stateless EJB with @Inject into CDI Weld ManagedBean (JSF 1.2 EJB Application on jboss 6 AS)    stackoverflow.com

currently i am trying to inject a stateless EJB into a CDI managed controller on Jboss 6 AS Final. The controller is managed in the context an accessible from the ...

16. jsf application throwing java.awt.headlessexception on jboss    stackoverflow.com

I created jsf application on windows, It is working fine. I changed my working environment to linux. Now I clicked a fileupload control(rich faces) on my application, it is throwing application ...

17. How make Seam3 Solder with CDI work in WebSphere 7?    stackoverflow.com

I want to use Seam Solder and Seam Faces 3 in WebSphere 7 with JSF 2.0 (RI is Mojarra 2.0.4) and CDI. I Included all required dependencies (Weld 1.1, JBoss Logging), ...

18. JBoss Weld + java.lang.OutOfMemoryError: PermGen space    stackoverflow.com

I've just switched to Weld to make use of CDI JSF 2 Beans + conversation scope. Here's my maven dependency :


19. JSF 2 and EJB 3 with JBoss 6 - @PostConstruct get not called    stackoverflow.com

I tried out using EJB 3.0 on a JBoss 6.0, injection is working but methods with @PostConstruct annotations get never called. Im using

  • jboss-6.0.0.Final
    • Java 6
    • JSF
       o jsf-api 2.0.3
       o jsf-impl 2.0.3
    • javaee-api 6.0
    • [jpa 2.0 ...

20. Weld 1.1.0-Final : Cannot inherit from final class    stackoverflow.com

After some frustations with this, i decided to try out the newer Weld, which is 1.1.0-Final, and here' the maven i added successfully:


21. Is there a configuration setting for JBoss 5.0 to control the order in which ear files are deployed?    stackoverflow.com

Is there a mechanism either within the ear file itself (jboss-app.xml) or a configuration on the server to ensure that an EAR is loaded last and/or after another ear? For ...

22. Does anyone have experience of using jsf4birt under JBoss 6?    stackoverflow.com

I would like to use jsf4birt to put birt report into xhtml pages. I tried to deploy exadel-jsf4birt-demo.war under jboss 6 but failed. Max@exadel said that jsf4birt only suppourts JSF 1.2, ...

23. configure JNDI lookup port jboss + EJB    stackoverflow.com

I am using JSF and EJB as two separate project in my application. Below i described code used to JNDI lookup

protected final Object lookup(Class className) throws NamingException {


24. How to create a modular JSF 2.0 application?    stackoverflow.com

I have an application with a well defined interface. It uses CDI for resolution of the modules, (Specifically it uses Instance<> injection points on API interfaces to resolve modules) and ...

25. Modular JSF applications with Jboss    stackoverflow.com

We are trying to build a modular jsf application. The application consists of a war file and several jar files. Each jar file contains .xhtml pages , associated beans and configuration ...

26. JBoss Changing sessionId JSF    stackoverflow.com

Hi I have problem with the session Id being changed in Jboss 7, this dosen't happen in Jboss 6. Is there a setting that I am missing. If anyone has any ...

27. JSF code displayed on browser    stackoverflow.com

I am learning JSF and got help from Exadel.com. I followed the steps described there. The web.xml:

<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns="http://java.sun.com/xml/ns/javaee" xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"

28. JSF life after logout    stackoverflow.com

I'm using form based authentication. I have a logout link which looks like:

<h:commandLink action="#{loginBean.logout}">
    <h:outputText value="logout" />
And the corresponding logout method:
public String logout() {


29. Highest supported JSF version for JBoss 4.0?    stackoverflow.com

I am using jboss 4.0 and Java 1.5. I want to use JSF, but I know that this version is fit to JSF 1.1 version. Is it possible to use the ...

30. jsf-api maven dependencies in JBoss 6.1.0.Final    stackoverflow.com

I am trying to update an old EAR that was working on JBoss 5 to run under JBoss 6.1.0.Final. The EAR contains a WAR which had a dependency on jsf-api and jsf-impl. ...

31. Referencing CDI producer method result in h:selectOneMenu    stackoverflow.com

I have a named session scoped bean CustomerRegistration which has a named producer method getNewCustomer which returns a Customer object. There is also CustomerListProducer class which produces all customers as list ...

32. JSF in clustered environment    stackoverflow.com

I use clustered Jboss AS 5.1 and JSF 5.0. Could you suggest me if specific configuration is necessary. I have added </distributed> only. Currently I get exception for some links:


33. ClassNotFoundException while loading dynamically generated class file using the classloader in JBOSS 5    stackoverflow.com

We are generating the managed bean(JSF2 managed bean) classess dynamically at the runtime by generating the java code and compiling the same. The generated class file is placed ...

34. ConversationScope not available before JSF2 RestoreView    stackoverflow.com

I've moved my "gatekeeper" function to Before Restore View after upgrading to JBoss 7.0.2 and the latest Majorra as answered at JSF2 Sending a redirect from Before Restore View phase ...

35. Jboss and JSF    community.jboss.org

The issue was when i try to access a page,i was getting "502 bad gateway error".The page contains a database access.when i request the page ,

37. JSF not working in Jboss    coderanch.com

39. Deploying JSF App On JBoss    coderanch.com

I am having a problem deploying my JSF application onto Jboss, I have been able to deploy on Tomcat and Sun Application server without issues but whenever i try to deploy on Jboss 4.2.0 i am always getting the following errors ****************************************************** 16:24:27,453 INFO [STDOUT] 16:24:27,437 ERROR [[/talents]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener java.lang.ClassCastException: com.sun.faces.config.WebConfiguration ...

40. Migrating JSF app from JBOSS AS 4.0.5 to 4.2.0    coderanch.com

Hi all! I have JSF App which is based on MyFaces impl 1.1.5 ver + Tomahawk and it is using Tiles (by special filter from Tomahauk) It works fine on 4.0.5, but when I'm trying to migrate on 4.2.0 - it didn't work. My steps: due WIKI I decided to use JSF Impl which is bundled with new JBOSS. I had ...

41. shale with JBoss    coderanch.com

42. Problem in deploying JSF in JBoss 4.0.0    coderanch.com

org.apache.jasper.JasperException: Unable to compile class for JSP An error occurred at line: 5 in the jsp file: /Demo.jsp Generated servlet error: E:\JBOSS\jboss-4.0.0\server\default\work\jboss.web\localhost\abhi\org\apache\jsp\Demo_jsp.java:83: cannot access com.sun.faces.taglib.jsf_core.ViewTag An error occurred at line: 5 in the jsp file: /Demo.jsp Generated servlet error: bad class file: E:\JBOSS\jboss-4.0.0\server\default\deploy\abhi.war\WEB-INF\lib\jsf-impl.jar(com/sun/faces/taglib/jsf_core/ViewTag.class) class file has wrong version 49.0, should be 48.0 Please remove or make sure it appears in the ...

43. JSF and TLD descriptors in JBoss    coderanch.com

Dear Ranchers, I am very new to JSF (have little experience with JSP) and I tried to create a same application with netbeans and it worked very well.. I understand that JSF is build on the top of JSP or rather servlet by defining custom JSP tag.. But I couldn't find any tld descriptor in the sample applicaiton i deployed using ...

44. jsf app not able to deploy in jboss    coderanch.com

45. JSF 1.2 in jBoss 4.2.2GA    coderanch.com

46. JBoss, Tomahawk, Stack Overflow.    coderanch.com

48. JAAS Implementation with JBOSS    coderanch.com

50. deployment problem in Jboss    coderanch.com

52. Problem while configuring JSF with JBOSS 4.0.4.GA    coderanch.com

Hi, I am having problems while configuring JSF application. am getting below exception in the console and am not able to access the application properly: 12:11:22,055 ERROR [UIComponentTag] Faces context not found. getResponseWriter will fail. Check if the FacesServlet has been initialized at all in your web.xml. 12:11:22,057 ERROR [[jsp]] Servlet.service() for servlet jsp threw exception java.lang.NullPointerException at javax.faces.webapp.UIComponentTag.setupResponseWriter(UIComponentTag.java:929) at javax.faces.webapp.UIComponentTag.doStartTag(UIComponentTag.java:310) ...

54. Getting JSF 2.0 to work with JBoss    coderanch.com

55. Jboss not deploying my projects    coderanch.com