jboss « IceFaces « JSF Q&A

1. JBoss RichFaces vs IceFaces vs Apache Trinidad - JSF component libraries comparison    stackoverflow.com

What do you think/use for interface layer? The "backing" layer will be Spring 3. The criteria are :

  • Your private opinion
  • Components
  • Documentation
  • AJAX Integration
  • Browser support
  • Community
  • Tool support (Eclipse, NetBeans)
I found some comparison topics but it was ...

2. JDT Compiler Exception    stackoverflow.com

java.lang.NoSuchMethodError: org.eclipse.jdt.internal.compiler.CompilationResult.getProblems()[Lorg/eclipse/jdt/core/compiler/IProblem;
 at org.apache.jasper.compiler.JDTCompiler$2.acceptResult(JDTCompiler.java:329)
 at org.eclipse.jdt.internal.compiler.Compiler.handleInternalException(Compiler.java:502)
 at org.eclipse.jdt.internal.compiler.Compiler.compile(Compiler.java:430)
 at org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:387)
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java:288)
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java:267)
 at org.apache.jasper.compiler.Compiler.compile(Compiler.java:255)
I am getting the above exception... any ideas?
  1. JBoss (MX MicroKernel) [4.2.3.GA
  2. JDK 1.6
  3. Icefaces 1.8.2

3. Upgrade project to ICEfaces 2.0    stackoverflow.com

I have a project in JSF 1.2 and ICEfaces 1.8. I have started the upgrade process to JSF 2.0 and ICEfaces 2.0 based on this tutorial I've DELETED old JSF and ...

4. Alternative JSF implementation with JBoss 71    stackoverflow.com

I am trying to use icefaces 1.7.1 in a war application deployed on JBoss 7.0.0.Final Deployment is failing with an error "Could not compile stylesheet" in icefaces-comp.jar/META-INF/faces-config.xml. I assume this is ...

5. jboss deploy problems in icefaces    coderanch.com

8. Ice Faces 1.7.2 not workin with Jboss 4.0.5 GA    icefaces.org

Im trying to develop a simple application using Netbeans 6.1, Ice Faces 1.7.2 and Jboss 4.0.5 GA. The following erro appears when i try to deploy it: 16:16:44,906 ERROR [[/TestApp]] Error configuring application listener of class com.sun.faces.config.ConfigureListener java.lang.NoClassDefFoundError: javax/el/CompositeELResolver at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2357) at java.lang.Class.getConstructor0(Class.java:2671) at java.lang.Class.newInstance0(Class.java:321) at java.lang.Class.newInstance(Class.java:303) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3712) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4211) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:759) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:739) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:524) at ...

10. Unable to submit form in JBoss    icefaces.org

12. JBoss 5.GA & IceFaces    icefaces.org

2009-01-08 14:18:44,320 DEBUG [com.icesoft.jasper.compiler.TldLocationsCache] (http- Initializing ICEfaces TldLocationsCache 2009-01-08 14:18:44,476 ERROR [com.icesoft.faces.webapp.parser.JspPageToDocument] (http- Can't find TLD for location [http://www.w3.org/1999/xhtml]. JAR containing the TLD may not be in the classpath 2009-01-08 14:18:44,476 ERROR [com.icesoft.faces.webapp.parser.Parser] (http- Failed to execute JSP lifecycle. java.lang.IllegalStateException: ICEfaces parser unable to determine JSF implementation ViewTag class. at com.icesoft.faces.webapp.parser.Parser.parse(Parser.java:152) at com.icesoft.faces.application.D2DViewHandler.renderResponse(D2DViewHandler.java:528) at com.icesoft.faces.application.D2DViewHandler.renderView(D2DViewHandler.java:159) at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:110) at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:100) at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139) ...

13. Ice faces page in jboss welcome file list    icefaces.org

Hi Judy, Checked this out and it seems to do this via a redirection from an index.html page. We don't want to do this as it apparently effects the way the page is indexed. What we want to do is to have the context root /order go to our order page? i.e. not using /order/main.seam I have tried this in the ...

14. actionListener doesn't work with JBOSS    icefaces.org

Hello, i'm currently using JBOSS 4.2.2 with icefaces 1.7.2 and actionListener does not work. Here is my jboss console trace : Code: 18:00:10,286 INFO [TomcatDeployer] deploy, ctxPath=/testiface, warUrl=.../tmp/deploy/tmp4735534754958578518testiface-exp.war/ 18:00:10,940 INFO [D2DViewHandler] ICEsoft Technologies, Inc. ICEfaces 1.7.2 SP1 Build number: 11 Revision: 17935 18:00:11,300 INFO [ContextEventRepeater] Asynchronous HTTP Service available: true 18:00:11,301 INFO [ContextEventRepeater] JMS API available: true 18:00:11,331 INFO [JMSAdapter] Messaging ...

15. ICEfaces 1.7.2.SP1 + JBoss 5 + mod_jk    icefaces.org

16. Problem deploying icefaces application into jboss 5.0.0 GA    icefaces.org

Hello, i'm trying to migrate my application from TOMCAT 5 to jboss 5.0.0 GA and i'm having lots of problems. I saw that jboss already has some libraries that i don't have to put them in the lib directory. So i remove some of them and i fixed some problem (ie, SaxParserExceptionm etc) My problem now is that i have the ...

18. problem when i place icefaces jar file in Jboss lib(not in application)    icefaces.org

hi, I am using the Jboss1..8.1 and jboss-4.2.3.GA as application server. I placed the jar(commons-beanutils-1.7.jar,commons-collections-2.1.jar,commons-digester-1.7.jar,commons-logging-1.0.2.jar,icefaces.jar,icefaces-comps.jar,icefaces-facelets.jar) files requried for the applications in JBoss/server/default/lib . I have multiple Enterprise Applications deployed in the JBoss server. I am navigating from one application to another using PersistentFacesState.getInstance().redirectTo(".......") and passing the variables using the ServletContext. When i run the application and navigating the application I am ...

21. panelTabset selectedIndex does not update on JBoss 4.2.3 + Icefaces 1.8.1    icefaces.org

Hi all, I am developing a web app using the icefaces 1.8.1. I use panelTabset for the layout, and rely on the "selectedIndex" attribute to tune the behavior of a method. If I deploy the application on tomcat 6, there is no problem. The value of selectedIndex is set correctly on selection. If I deploy on Jboss 4.2.3, selectedIndex is not ...

22. Icefaces 1.8.1 with Jboss AS 4.2.3 Problem    icefaces.org

hi,,,I'm newbie on icefaces And I'm trying to run the samples apps ,,, component-showcase,,,run ok address,,,no errors when start jboss, but when I go to http://localhost:8080/address/ ,,, I don't see nothing,,,a white page without content,,and the jboss console don't show any error. the same problem with auctionMonitor sample and the same problem with a sample app based on tutorial of pdf ...

25. Not able to deploy ice faces 1.8.2 on jboss 5.0.0 ga    icefaces.org

hi i am able to deploy and run simple jsf application on jboss but not ice faces one. i have not included ice faces or jsfjar files in build path and kept them at ../jboss-5.0.0.GA/server/default/deploy/jbossweb.sar i am getting error java.lang.ClassCastException: org.jboss.web.tomcat.metadata.ListenerMetaData cannot be cast to org.jboss.web.tomcat.metadata.ListenerMetaData Any pointers? is the 5.0.0.ga version of jboss compatible with 1.8.2 version of icefaces?

28. From jboss-5.1.0.GA to jboss-4.0.5.GA    icefaces.org

Hi, I have many problems with the deployment of a webapp from Jboss 5 to Jboss 4. I created an application with JDK 1.5 under Jboss 5.1.0 and ICEfaces 1.8 and works well. But I need that this application is running under JBoss 4.0.5. The deployment appears to be correct but when i launch the application I get this error: HELP ...

29. ICEFaces 2 + JBoss 6 ZipException    icefaces.org

I am trying to upgrade an ICEFaces 1.8 application to ICEFaces 2 on JBoss 6 but I am getting this error on server startup: 14:48:05,750 SEVERE [config] Unable to process annotations for url, vfs:/D:/jboss6/server/default/lib/icefaces.jar/META-INF/faces-config.xml. Reason: java.util.zip.ZipException: error in opening zip file I have copied icefaces.jar, icefaces-compat.jar and all of the jars from the compat folder into the lib directory of the ...

30. ICEFaces Issue with JBoss 6    icefaces.org

31. ICEFaces Issue with JBoss 4.2    icefaces.org

Hi, I have an application with only single page displaying "Welcome to Icefaces" and a command button which prints "hello world" after clicking. I am able to run this application on Tomcat 6 but with Jboss 4.2 , I am able to run the application but clicking doesnot works. I am also not getting any error. just clicking and clicking and ...

32. [JSF 2.0][Icefaces 2] with jboss 4.2    icefaces.org

33. ICEfaces sample applications do not initialize correctly under JBoss AS 4.0.5 GA    icefaces.org

Hi, all! I'm having problem with initializing ICEfaces sample applications within JBoss AS 4.0.5 GA environment. My configuration is as follows: 1. JDK 5.0; 2. JBoss AS 4.0.5 GA - pure installation ( without EJB3 ); 3. address.war put into $JBOSS_HOME/server/default/deploy. I got an exception during startup: 2007-02-15 11:44:33,609 ERROR [com.icesoft.faces.webapp.xmlhttp.PersistentFacesCommonlet] ICEfaces could not initialize JavaServer Faces. Please check that the ...

35. JBoss 4.2.0.GA    icefaces.org

36. getting exception with jboss4.2.0GA AS    icefaces.org

osudheer Joined: 30/11/2006 00:00:00 Messages: 32 Offline HI , till now I used jboss4.0.2 with Icefaces 1.5.3.Now I upgrade the server to jboss4.2GA and Icefaces 1.6 DR5 .but I am getting following exceptions please help me to solve this issue 16:50:24,968 INFO [TomcatDeployer] deploy, ctxPath=/MozartVP1, warUrl=.../deploy/MozartVP1.war/ 16:50:27,765 INFO [WebappClassLoader] validateJarFile(C:\Documents and Settings\osudheer\Desktop\latestV\jboss-4.2.0.GA\jboss-4.2.0.GA\server\default\.\deploy\MozartVP1.war\WEB-INF\lib\servlet-api.jar) - jar not loaded. See Servlet Spec 2.3, section ...

37. Running component-showcase example in JBOSS 4.2.0GA    icefaces.org

Hi, I'm unable to run component-showcase example in JBOSS 4.2.0GA. Below are steps that I followed to run this example. 1. Copied D:\All_My_Applications\JBOSS\jboss-4.2.0.CR2\server\default to D:\All_My_Applications\JBOSS\jboss-4.2.0.CR2\server\icsfaces folder. 2. Copied component-showcase.war file to D:\All_My_Applications\JBOSS\jboss-4.2.0.CR2\server\icsfaces\deploy folder. 3. started JBOSS from D:\All_My_Applications\JBOSS\jboss-4.2.0.CR2\bin folder as run -c icefaces. 4. I get following error. [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/component-showcase]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener java.lang.ClassCastException: ...

38. Problem running Icefaces 1.6 in JBoss 4.2.0-GA    icefaces.org

Installed fresh JBoss environment, deployed the components-showcase war from Icefaces 1.6, and got the following exception: 19:48:06,413 INFO [TomcatDeployer] deploy, ctxPath=/component-showcase, warUrl= .../tmp/deploy/tmp51381component-showcase-exp.war/ 19:48:08,125 INFO [D2DViewHandler] ICEsoft Technologies, Inc. ICEfaces 1.6.0 Build number: 15 Revision: 14409 19:48:08,986 ERROR [[/component-showcase]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener java.lang.ClassCastException: com.sun.faces.application.ApplicationAssociate at com.sun.faces.application.ApplicationAssociate.getInstance(ApplicationAssociate.java:172) at com.sun.faces.config.JSFVersionTracker.publishInstanceToApplication(JSFVersionTracker.java:266) at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:424) at org.jboss.web.jsf.integration.config.JBossJSFConfigureListener.contextInitialized(JBossJSFConfigureListener.java:69) at ...

39. IceFaces 1.6.0 + facelets + jboss 4.2.0 NOT WORKING?    icefaces.org

Hi, I deployed the 1.6.0 component showcase example to jboss 4.2.0 without facelets an it worked correctly. Then I deployed it including the facelets configuration and got a whole bunch of errors. So I did a small test case to reproduce the problem. It is included with the generated log Perhaps there is need of some other libraries when using facelets? ...

40. Running Simple Example on Jboss 4.2 with facelets    icefaces.org

I am trying to run a simple web page using Jboss 4.2 IceFaces 1.6 and Facelets. When Jboss starts up, my WAR file does not load and there is an error in the log that says: 2007-08-24 13:57:43,390 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/iceFacesTutorial]] com.icesoft.faces.component.outputchart.OutputChart javax.faces.FacesException: java.lang.UnsupportedOperationException..... I have followed the examples in the tutorial, but haven't been able to come up with something that ...

41. Session Expirred Issue JBoss 4.2.1    icefaces.org

42. Jboss + IceFaces and 2 applications with the same session    icefaces.org

Hello, I have a problem with Jboss 4.2.1 and IceFaces 1.6.1 I have deployed two applications (desktop.war and webmail.war) in a JBoss 4.2.1 and the server.xml enabled the SingleSingOn to keep the authentification between the two applications, so that when calling from one to another not ask again login and password. I also installed the Async ...

44. ICEfaces and Facelets on JBoss 4.2.1    icefaces.org

45. ReferenceSyntaxException in Jboss    icefaces.org

Hello, to make Deploy in Jboss 4.2.1 and run my application I generated the following error; 15:58:01,750 INFO [STDOUT] error Error==>javax.faces.el.ReferenceSyntaxException: #{indexApp.salir_accion} I am creating a dynamically MenuBar. Somebody knows it is? MenuItem topLevel = new MenuItem(); topLevel.setValue(menuItemDTO.getMenu().getNombre()); topLevel.setLink(menuItemDTO.getMenu().getUrl()); if (menuItemDTO.getMenu().getAccion() == null || menuItemDTO.getMenu().getAccion().equals("")) { } else { Class args[] = { ActionEvent.class }; topLevel.setAction(FacesContext.getCurrentInstance().getApplication() .createMethodBinding(menuItemDTO.getMenu().getAccion(), args)); }

46. ICEFaces on jboss 4.2.2    icefaces.org

47. Problem deploying 1.7 DR2 component showcase on JBoss 4.2.2 GA    icefaces.org

zzzz8 Joined: 07/12/2005 00:00:00 Messages: 246 Offline I get the following exceptions: Code: 12:01:25,359 INFO [TomcatDeployer] deploy, ctxPath=/component-showcase, warUrl= .../tmp/deploy/tmp37408component-showcase-exp.war/ 12:01:31,234 INFO [D2DViewHandler] ICEsoft Technologies, Inc. ICEfaces 1.7.0 DR2 Build number: 5 Revision: 15004 12:01:33,000 ERROR [[/component-showcase]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJ SFConfigureListener java.lang.ClassCastException: com.sun.faces.application.ApplicationAssociate at com.sun.faces.application.ApplicationAssociate.getInstance(Applicatio nAssociate.java:172) at com.sun.faces.config.JSFVersionTracker.publishInstanceToApplication(J SFVersionTracker.java:266) at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureLi stener.java:408) at ...

49. Can't run samples apps on JBoss 4.2. Please help    icefaces.org

Hi, I downloaded ICEfaces-1.6.1-bin and also the eclipse integration (ICEfaces-Eclipse-IDE-v3.0.0.zip ) I'm also using JBoss 4.2 which includes jsf1.2 libraries. I followed the step by step instructions and created a simple dynamic web project - "icefaces style". After deploying the application I get a deployment exception, and I can't run the application. (I overcomed the first error by adding commons-digester.jar to ...

50. File Upload Jboss to Apache    icefaces.org

52. Deployment-Error: JBoss 4.2 and IceFaces 1.6    icefaces.org

Hi, I tried to deploy an application (JSF 1.1, Icefaces 1.6, JBoss 4.2) and I got a strange error: 2008-03-04 12:33:16,109 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/Blb_RcZl_ParameterMdb_WebApp]] Exception sending context initialized event to listener instance of class org.jboss.web.jsf.integration.config.JBossJSFConfigureListener java.lang.ClassCastException: com.sun.faces.application.ApplicationAssociate at com.sun.faces.application.ApplicationAssociate.getInstance(ApplicationAssociate.java:172) at com.sun.faces.config.JSFVersionTracker.publishInstanceToApplication(JSFVersionTracker.java:266) at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:408) at org.jboss.web.jsf.integration.config.JBossJSFConfigureListener.contextInitialized(JBossJSFConfigureListener.java:69) at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3856) at org.apache.catalina.core.StandardContext.start(StandardContext.java:4361) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:790) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:770) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:553) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) ...

54. Error with JBOSS    icefaces.org

18:06:12,557 INFO [ConnectionFactoryBindingService] Unbound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=OracleDS' from JNDI name 'java:OracleDS' 18:06:12,842 INFO [ConnectionFactoryBindingService] Bound ConnectionManager 'jboss.jca:service=DataSourceBinding,name=OracleDS' to JNDI name 'java:OracleDS' 18:19:43,412 WARN [JBossManagedConnectionPool] Throwable while attempting to get a new connection: null org.jboss.resource.JBossResourceException: Could not create connection; - nested throwable: (org.jboss.resource.JBossResourceException: Apparently wrong driver class specified for URL: class: oracle.jdbc.drive r.OracleDriver, url: jdbc:oracle:thin:@

55. JBoss + Icefaces    icefaces.org

56. JBoss 4.3GA Problem running component-showcase    icefaces.org

Hi ... build the component-showcase.war file using tomcat6.0 and jboss4.2 targets. I also removed the jsf*.jar files from the war file. Now, getting error: Error configuring application listener of class com.sun.faces.util.ReflectionUtils$ReflectionUtilsListener If I put the jsf*.jar files back into the war, I'm getting this error: ERROR [application] JSF1029: The specified InjectionProvider implementation 'org.jboss.web.jsf.integration.injection.JBossInjectionProvider' does not implement the InjectionProvider interface. I've tried ...

57. Can't add ICEfaces using a JBoss 4.2.1 Server    icefaces.org

Hi, I'm using JBoss 4.2.1, MyEclipse 6 and ICEfaces 6 OR MyEclipse 6.5 and ICEfaces 7. If I create a new web app, then add JSF, then deploy and start server all is well. Once I add ICEfaces I get the following error. Help, I'd like to use ICEfaces but I have to use JBoss 4.2.1server 14:36:21,621 INFO [DLQ] Bound to ...

58. liferay vs jboss vs exo    icefaces.org

Anyone has a link to compare features of these 3 open src. portals ? If you have time, I'd like to know reasons why you pick particular one? I am interested in: - features (mails, events, JPA vs. SPRING/HIBERNATE) - quality of support Thanks everyone who writes something on this. Of course I plan to use one of them with icefaces, ...

59. Blank page with navigator refresh button and new JBOSS version 4.2.3    icefaces.org

Hi all, I just upgraded my jboss to 4.2.3 My IceFaces applications are working fine. But when I'm refreshing them with refresh button from navigator, the page becomes blank and it is impossible to come back to the ICEFaces application. I must close navigator or clear session. What should I do ? Is it an ICEFaces incompatibility with JSF 1.2-09-BETA1 jboss ...