DFS « hadoop « Java Database Q&A





1. Hadoop DFS Error    stackoverflow.com

Can someone tell me what I am doing wrong? 2009/08/10 11:33:07 [INFO] - Copying local:/ X/Y/Z.txt to DFS:/X/Y/Z.txt 2009/08/10 11:33:07 [INFO] - put:
org.apache.hadoop.fs.permission.AccessControlException: Permission denied: user=superman, access=WRITE, inode="":big-build:supergroup:rwxr-xr-x 2009/08/10 11:33:08 [FATAL] ...

2. Hadoop DFS Permission Error    stackoverflow.com

2009/08/11 13:25:39 [INFO] - put: org.apache.hadoop.fs.permission.AccessControlException: Permission denied: user=yskhoo, access=WRITE, inode="":bad-boy:supergroup:rwxr-xr-x Why do I keep getting this error? Also is it bad that I am writing to a ...

3. Wiping out DFS in Hadoop    stackoverflow.com

How do I wipe out the DFS in Hadoop?

4. Hadoop dfs -ls returns list of files in my hadoop/ dir    stackoverflow.com

I've set up a sigle-node Hadoop configuration running via cygwin under Win7. After starting Hadoop by

bin/start-all.sh
I run
bin/hadoop dfs -ls
which returns me a list of files in my hadoop ...

5. Changing the block size of a dfs file in Hadoop    stackoverflow.com

I found that my map tasks is currently inefficient when parsing one particular set of files (total 2 TB). I'd like to change the block size of files in the Hadoop ...

6. Is there any distributed file system which runs on Windows except Hadoop?    stackoverflow.com

I'm desperate to find any DFS which supports Windows. The only such DFS is Hadoop HDFS but it's very hard to deploy it other big number of Windows machines because it ...

7. Can cat but cannot ls file in Hadoop DFS    stackoverflow.com

This is the weirdest thing ever. So I can see these files and cat them:

[jchen@host hadoop-0.20.2]$ bin/hadoop fs -ls /users/jchen/            ...

8. What is the fastest way to transfer data from Hadoop DFS to a local filesystem?    stackoverflow.com

I always use "dfs -get" or "dfs -cat", but I imagine there might be something better. With "dfs -cat | pv", it appears my network connection isn't saturating (I'm getting only ...

9. Hadoop DFS is pointing to current directory    stackoverflow.com

A few months ago, we installed CLoudera Hadoop 3 in our local machine and everything was fine. Recently we also installed Whirr to start working with clusters. Although we faced some ...





10. Exception during start.dfs.sh    stackoverflow.com

I set up a two node cluster using hadoop. When I run start-dfs.sh I got this error:

starting namenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-namenode-mohit-ubuntu.out
slave: starting datanode, logging to /usr/local/hadoop/bin/../logs/hadoop-hadoop-datanode-balaji-ubuntu.out
slave: Exception in thread “main” java.lang.NoClassDefFoundError: org/apache/hadoop/util/PlatformName
slave: ...

11. Hadoop DFS permission issue when running job    stackoverflow.com

I'm getting this following permission error, and am not sure why hadoop is trying to write to this particular folder:

hadoop jar /usr/lib/hadoop/hadoop-*-examples.jar pi 2 100000
Number of Maps  = 2
Samples per ...

12. Hadoop dfs.include file    stackoverflow.com

Please explain what's dfs.include file purpose and how to define it. I've added a new node to the Hadoop cluster but it's not identified by the namenode. In one of the posts ...

13. How do I hide "DFS Locations" in the Project Explorer when I'm not in the Map/Reduce Perspective?    stackoverflow.com

In Eclipse Indigo 3.7, I am using the Hadoop plug-in from the 0.20.2 release. The plug-in works well and has some nice features like the "DFS Locations" entry in the Project ...