exception « oracle « Java Database Q&A

1. Can someone explain this JDBC Exception to me?    stackoverflow.com

I'm gettting the following exception when performing an insert to an Oracle Databse using JDBC.

java.sql.SQLRecoverableException: Io exception: Unexpected packet
What could cause this and how can I recover from it? The application I'm ...

2. Custom oracle exceptions through JDBC    stackoverflow.com

In a stored procedure I have used to;

raise_application_error (-20010, 'My Message');
to raise a custom error in a certain situation. What I am trying to do is when I make my JDBC ...

3. Java find the first cause of an exception    stackoverflow.com

I need to check if an exception is caused by some database problem. I receive an Exception and check if its cause contains the "ORA" string and return that (something like ...

4. What could be the possible cause of this exception?    stackoverflow.com

I get the following error when I run a java program:

Exception in thread "main" java.lang.UnsatisfiedLinkError: t2cPingDatabase
        at oracle.jdbc.driver.T2CConnection.t2cPingDatabase(Native Method)

5. PL/SQL exception and Java programs    stackoverflow.com

Business logic is coded in pl/sql packages procedures and functions. Java programs call pl/sql packages procedures and functions to do database work. pl/sql programs store exceptions into Oracle tables whenever an exception is ...

6. Oracle enterprise manager java.lang.Exception    stackoverflow.com

After creating a db using Database Configuration Assistant, I go to Enterprise Manager, log into it, and it tells me, that java.lang.Exception: Exception in sending Request :: null. OracleDBConsole for this ...

7. Oracle Connection exception via JDBC    stackoverflow.com

I have installed Oracle 11gR2 on my machine, now when i try to connect to it using IP address as 'localhost' or '' there is no issue, but when I use ...

8. getting class not found exception    stackoverflow.com

Hi friends i am facing the following error while trying to connect to a database through java code:

Exception in thread "Main Thread" java.lang.ClassNotFoundException: oracle.jdbc.OracleDriver
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at com.example.model.Driver.main(Driver.java:13)
My java code is:
package ...

9. Please advise on the exception    stackoverflow.com

Can any body tell me what this exception means, its confusing because I tried all possible ways to change the path of the keystore.. doesn't work. Environment: ORACLE database server, configuring SSL

Exception ...

10. Java Heap Space Exception, with big ammount of data, any solution?    stackoverflow.com

I've a litle big problem with java heap memory I'm trying to migrate from oracle database 11g to access file 2007 This is not a problem below 65.000 records, now from there... The aplication ...

11. SQLRecoverableException: I/O Exception: Connection reset    stackoverflow.com

yesterday evening i left the office with a running java program wrote by me it should insert a lot of records into our company DB (oracle), using a JDBC connection this morning ...

12. Socket Exception : recv failed with oracle thin driver    stackoverflow.com

I am facing an issue where my test suite randomly fails with an socket exception

oracle.jdbc.driver.T4CStatement 1267 - Throwing SQLException: java.net.SocketException: Software caused connection abort: recv failed 

The test suite fails ...

13. Raising errors from Java stored procedures without "ORA-29532 Java call terminated by uncaught Java exception"    stackoverflow.com

Suppose you have a Java class which defines a copyFile(String, String) method:

public class FileSystem {

    public static void copyFile(String sourcePath, String destinationPath)

14. The Network Adapter could not establish the connection when connecting with Oracle DB    stackoverflow.com

When trying to connect with a remote Oracle database via JDBC I receive the following exception:

java.sql.SQLRecoverableException: IO-fout: The Network Adapter could not establish the connection
at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:419)
at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:536)
at oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:228)
at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:32)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:521)
at java.sql.DriverManager.getConnection(DriverManager.java:322)
at ...

16. When is the Exception thrown in case of Oracle driver when calling a stored procedure    coderanch.com

Hello all, For executing a stored procedure one does something like the following: CallableStatement cStmt = Connection.prepareCall(sql); cStmt.registerOutParameter(parameterIndex,sqlType); cStmt.setString("blah"); cStmt.execute() result = cStmt.getString(index); Now according to javadoc the Exception can be thrown at either when doing the Connection.prepareCall(..) or when doing the CallableStatement.execute() and its supposed to be depenedent on the driver. I am using the Oracle driver from classes111.zip but ...

17. oracle exception    coderanch.com

I have stored procedure which takes in a bunch of paramaters and inserts a row in a table. When one of the parameters happens to be larger than the size of the column of the database table I am gettting back an error whose decription is "value trying to insert is larger than the column size". It takes me some time ...

18. Class Not Found exception connecting to Oracle    coderanch.com

Selvi, Welcome to JavaRanch! Your jar is in the right place. Things that are part of the application go in WEB-INF. Things used by the server go in the tomcat directory. I think the jar might be misnamed. Oracle traditionally calls its driver classes12.jar. Another thing is to try unzipping the jar into a temporary directory and making sure it has ...

20. Oracle 10G - EXCEPTION_ACCESS_VIOLATION    coderanch.com

Started with Oracle 9, Hibernate 3, Weblogic 81sp5, everything fine. Upgraded to Oracle 10G, and getting EXCEPTION_ACCESS_VIOLATION. Any thoughts? An unexpected exception has been detected in native code outside the VM. Unexpected Signal : EXCEPTION_ACCESS_VIOLATION (0xc0000005) occurred at PC=0x61D4894C Function=xaolog+0x6294 Library=c:\ora10g\bin\OraClient10.Dll Current Java thread: at oracle.jdbc.driver.T2CStatement.t2cParseExecuteDescribe(Native Method) at oracle.jdbc.driver.T2CPreparedStatement.executeForDescribe(T2CPreparedStatement.java:518) at oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1037) at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1132) at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3316) at oracle.jdbc.driver.OraclePreparedStatement.executeQuery(OraclePreparedStatement.java:3361) - locked <0x10234c00> (a ...

22. Oracle Exception    coderanch.com

23. The best way to catch Oracle exceptions    coderanch.com

Hi all. I created some exceptions to validate inserts in Oracle because I want to show a friendly message for the user case some error (like PK, FK) occurs. I want to know if it's the best way. Look at the code: try { OracleCustomerDAO.insertCustomer(cus); } catch (PKException e) { System.out.println("invalid primary key"); } catch (FKException e) { System.out.println("Invalid foreign key"); ...

24. Exception while connecting to an Oracle database    coderanch.com

public class OracleConnection { static final String DB_DRIVER = "oracle.jdbc.OracleDriver"; static final String DB_URL = "jdbc:oracle:thin:system/system@//localhost:1521/orcl"; private Connection conn; private Statement st; public OracleConnection() { try { Class.forName("oracle.jdbc.OracleDriver"); } catch (ClassNotFoundException e) { e.printStackTrace(); } try { conn = DriverManager.getConnection(DB_URL, "system", "system"); st = conn.createStatement(); } catch (SQLException e) { e.printStackTrace(); } }

25. Exception when sending query to oracle    java-forums.org

Hi, I have java application that send queries to oracle DB. In some cases I got exception. If I catch this exception and send again the same query it works OK. What can cause this issue ? The exception: java.lang.ArrayIndexOutOfBoundsException : -2 oracle.jdbc.driver.T4CStatement.saveDefineBuffersI fRequired(T4CStatement.java:464) oracle.jdbc.driver.OracleStatement.prepareAccessor s(OracleStatement.java:927) oracle.jdbc.driver.OracleStatement.executeMaybeDes cribe(OracleStatement.java:1047) oracle.jdbc.driver.T4CStatement.executeMaybeDescri be(T4CStatement.java:830) oracle.jdbc.driver.OracleStatement.doExecuteWithTi meout(OracleStatement.java:1132) oracle.jdbc.driver.OracleStatement.executeInternal (OracleStatement.java:1687) oracle.jdbc.driver.OracleStatement.execute(OracleS tatement.java:1653)

26. classnotfound exception in running thin client with oracle    forums.oracle.com

java.sql.SQLException: Listener refused the connection with the following error ORA-12505, TNS:listener does not currently know of SID given in connect descrip or The Connection descriptor used by the client was: at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.jav :112) at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.jav :261) at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:387) at oracle.jdbc.driver.PhysicalConnection.(PhysicalConnection.java 420) at oracle.jdbc.driver.T4CConnection.(T4CConnection.java:165) at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtensi n.java:35) at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:801) at java.sql.DriverManager.getConnection(Unknown Source) at java.sql.DriverManager.getConnection(Unknown Source) at OracleSQL.connect2DB(OracleSQl.java:15) at OracleSQL.main(OracleSQl.java:38)

27. Exception "not implemented for class oracle.jdbc.driver.T4CNumberAccessor"    forums.oracle.com

Hello I'm having some troubles dealing with 'java.sql.Date' I'm working with express edition database and I have three classes(different packages) 1.Mapper 2.Objects Class 3.ConsoleTest I need to get an arraylist of objects, some of which contain dates, but when try to do it I get this exception "java.sql.SQLException: Invalid column type: getDate not implemented for class oracle.jdbc.driver.T4CNumberAccessor" Do you have any ...