JBoss 3 « JBoss « Java Enterprise Q&A

1. Java Base64: Apache Commons vs. JBoss    stackoverflow.com

I would like to know if anyone has experience using the following two APIs for Base64 handling on Java (with links to the respective Javadoc):

2. MissingResourceException - Java 5, JBoss 5.0, XSLT    stackoverflow.com

I have written sample program which uses XSLT to generate HTML response. Check below files. welcome.xsl

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
xmlns:java="http://xml.apache.org/xalan/java" version="1.0">
<xsl:output method="html" indent="yes" />
<xsl:variable name="myResource" select="java:java.util.ResourceBundle.getBundle('com.carbonrider.web.xslt.AppResources')" />
<xsl:template match="/">
<xsl:apply-templates />
<xsl:template match="first">
<xsl:value-of select="java:getString($myResource,'hi')" />
package curiousmind.web.xslt;
import java.io.BufferedInputStream;
import java.io.ByteArrayInputStream;
import ...

3. A Query called many times whit diferent paramenters always returns the same first result    stackoverflow.com

I'm in my first jee project working whit jboss-4.2.3, hibernate-3.2, jpa, ejb-3
I have a Session Bean that looks like this:

package ...
import javax.persistence.EntityManager;
import javax.persistence.Query;
import ...

public class myBean implements myBeanLocal {

4. jboss. How to determine the concurrent user count along the time?    stackoverflow.com

Is there some tools to determine the concurrent user count in jboss? The issue is sometimes jboss crashed with outOfMemoryError. And I try to investigate the reason of the error. It ...

5. Infinispan MVCC with "put"    stackoverflow.com

I wanted to use Infinispan today in a sort of probably unfamiliar matter. I want to save a Variable, let's call it x a couple of times in the cache - while ...

6. Apache Commons VFS - cannot resolveFile    stackoverflow.com

The VFS method cannot process this URI ${jboss.server.temp.dir}/local/outgoing configured in jboss-beans.xml which is resolved to "C:\\Download\\jboss-eap-5.1.1\\server\\default\\tmp/local/outgoing" by JBoss. When I try to resolve the URI and get the file, it throws ...

7. Where do I place temporary data under JBoss?    stackoverflow.com

Under JBoss, where do I place temporary data that will be read through a web application, where the application will access this data, for example Excel files?

8. Hudson/Jenkins+JBoss[+Silk4J]    stackoverflow.com

We have web application for JBoss 5.1.
And we want to check hourly by Hudson/Jenkins that our application can start successfully.
How can we check it?
The problem is that it is impossible to ...

9. setting emptySessionPath to true in jboss    stackoverflow.com

I was trying to run my JBoss portal server on https and came across a attribute emptySessionPath in Connector configuration of my server.xml. I do not understand what emptySessionPath is and what ...

10. Login/Authentication api in jboss    stackoverflow.com

Is there any login/authentication api provided in JBoss for logging on a user. Currently my application makes a hit to j_security_check with username and password for authenticating the user. Is there any ...

11. How to shutdown JBOSS from jmx-console    stackoverflow.com

Is it possible to shutdown JBOSS from jmx-console?

12. allowMultipleLastResources in JBoss AS 6 Final    community.jboss.org

13. Timers not working on AS6    community.jboss.org

I'm trying to migrate an application from the JBossAS5.1.0GA to 6.0.0.Final and I'm having problems with the Timer service.

14. RESTEasy/Jersey conflict on JBoss AS 6    community.jboss.org

(This post has been significantly edited now that I've produced a proper test case and had a stupid mistake pointed out to me. Old text is struck so that responses seen ...

15. jboss unable to start    community.jboss.org

You can copy jdk1.6.0_25 simple to c:\ for test and set JAVA_HOME before starting jboss or edit run.conf.bat for this.

16. Query Time out in Jboss AS 6    community.jboss.org

We are using an rich faces application on a Jboss AS 6 server. We wanted to set a sql query timeout for the same, and thus added the following tags in ...

17. JBoss App working on Win XP is not on Win 7    community.jboss.org

I was working on a web application on Windows 7 and Eclipse (jee version). Then my bosses update my computer, but it's with Windows 7. I copied all the project setup ...

18. JBoss AS 7 Bayeux Support    community.jboss.org

I am attempting to implement a bidirectional connection between my web client and my web server. For this connection I am looking to use the Bayeux protocol. From my ...

19. How to connect to JBOSS AS7    community.jboss.org

javax.naming.CommunicationException: Could not obtain connection to any of these urls: jnp://localhost:5445 and discovery failed with error: javax.naming.CommunicationException: IP_ADD_MEMBERSHIP failed (out of hardware filters?) [Root exception is java.net.SocketException: IP_ADD_MEMBERSHIP failed (out of ...

20. Encryption fails with JBoss 6    community.jboss.org

21. Integrating CAS 3.3.3 with JBoss 5.1.0    community.jboss.org

Hi, Any help in this matter is appreciated. java.lang.RuntimeException: Specification violation [EJB3 JPA] - You have not defined a non-jta-data-source for a RESOURCE_LOCAL enabled persistence context named: CasPersistence Regards John ...

22. EhCache + JBoss 6 + Terracotta not running    forums.terracotta.org

Caused by: org.hibernate.cache.CacheException: net.sf.ehcache.CacheException: Unable to load class net.sf.ehcache.terracotta.ExpressEnterpriseTerracottaClusteredInstanceFactory. Initial cause was null at net.sf.ehcache.hibernate.EhCacheRegionFactory.start(EhCacheRegionFactory.java:89) at org.hibernate.impl.SessionFactoryImpl.(SessionFactoryImpl.java:238) [:3.6.6.Final] at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1872) [:3.6.6.Final] at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:906) [:3.6.6.Final] ... 73 more Caused by: net.sf.ehcache.CacheException: Unable to load class net.sf.ehcache.terracotta.ExpressEnterpriseTerracottaClusteredInstanceFactory. Initial cause was null at net.sf.ehcache.util.ClassLoaderUtil.createNewInstance(ClassLoaderUtil.java:109) at net.sf.ehcache.terracotta.TerracottaClusteredInstanceHelper.newClusteredInstanceFactory(TerracottaClusteredInstanceHelper.java:178) at net.sf.ehcache.terracotta.TerracottaClient.createNewClusteredInstanceFactory(TerracottaClient.java:201) at net.sf.ehcache.terracotta.TerracottaClient.createClusteredInstanceFactory(TerracottaClient.java:153) at net.sf.ehcache.CacheManager.init(CacheManager.java:343) at net.sf.ehcache.CacheManager.(CacheManager.java:230) at net.sf.ehcache.hibernate.EhCacheRegionFactory.start(EhCacheRegionFactory.java:70) ... 76 more Caused by: java.lang.ExceptionInInitializerError at net.sf.ehcache.terracotta.ExpressEnterpriseTerracottaClusteredInstanceFactory.(ExpressEnterpriseTerracottaClusteredInstanceFactory.java:37) ...

23. CORBA under JBoss    coderanch.com

24. JBoss 3.2.3 in Win98    coderanch.com

25. session-timeout doesn't work in JBoss - why not?    coderanch.com

I am trying to get control of session timeout interval in a JBoss (3.2) application served under apache. In production this will be run in a two-server cluster with sticky sessions, but never mind that, I can't even get it to work unclustered. Current web.xml defines 60. But we need to set it to 4 hours (240). However, I can't prove ...

26. Invalidating HttpSession on JBoss 4.2.2 vs. 5.0.0Beta    coderanch.com

Hello everyone I am an absolute beginner at servlet programming. I'm having a hard time figuring out why the HttpSession.invalidate() method behaves differently on JBoss 4.2.2GA and 5.0.0Beta4. My servlet is very simple: protected void doGet(HttpServletRequest request, HttpServletResponse response) throws ServletException, IOException { // Get/create session. HttpSession session = request.getSession(); // Print session id. PrintWriter printWriter = response.getWriter(); printWriter.println("session id: " ...

27. Programatically start/stop JBoss    coderanch.com

Hello. I'm trying to programatically start and stop JBoss server, but I'm having some problems. Actualy, my code to start/stop is as follows: import org.jboss.*; ... private void startJBoss() { try { String str[]={}; Class c = Class.forName("org.jboss.Main"); Main ob = (Main)c.newInstance(); ob.main(str); } catch (Exception e) { System.out.println(e.getMessage()); } } private void stopJBoss() { try { String str[]={"-S"}; Class c ...

28. Setting up JBoss, IntelliJ, and Java EE    coderanch.com

Okay, maybe I should have asked for help first. Im really confused. I want to run code examples in IntelliJ. All has been okay so far, but now that I am runnign code that uses Java EE, I have problems. Cant find javax.servlet.jsp, for example. I have downloaded JBoss, and the build.xml is referencing jars in JBoss, that I think should ...

29. JBoss 3 + Java 1.4 communicating with JBoss 5 + Java 6, is that possible?    coderanch.com

I have an interesting challenge and I would count on help from you. Must maintain a heterogeneous environment with different versions of Java and APPSERVER. Java Settings: 1) Weblogic 8.1 + JRockit 1.4 (BEA) 2) JBoss 3.2.3 + JDK 1.4 (Sun) 3) Java 1.4 (Sun) - Application client (Swing) 4) JBoss 5.1.0 + JDK 1.6 (Sun) Flow of communication: 1) Application ...

31. Dynamic JNLP not working with JBoss?    coderanch.com

<%@ page contentType="application/x-java-jnlp-file" %> <%@ page session="true" %> <% response.setDateHeader ("Expires", 0); //prevents caching at the proxy server %> Test admin Test Blah blah blah ...

32. Integrating jBPM-4.4 into jBoss 6.0.0.Final    coderanch.com

Hey guys!! I'm trying to integrate jBPM-4.4 into jBoss 6.0.0.Final. I used the jBPM-4.4 user guide and followed it word by word. Although, after the command "ant -Ddatabase=oracle demo.setup.jboss" is finished, and after I start my jBoss, either through the CMD or the Eclipse, I get the following error: 15:49:13,317 INFO [AbstractJBossASServerBase] Server Configuration: JBOSS_HOME URL: file:/C:/software/jbpm-4.4/jboss-6.0.0.Final/ Bootstrap: $JBOSS_HOME\server/default/conf/bootstrap.xml Common Base: ...

33. Newbie problem delpoying J2EE onto JBOSS with Eclispe! plz help!    dbforums.com

hi, I am following the Tutorial for building J2EE Applications using JBOSS and ECLIPSE at http://www.tusc.com.au/tutorial/html/chap3.html I have followed everything up to the end. It all worked until I ran my application and it gave me these..what's going on? is it becuz I am using different versions of stuff that they're using? javax.naming.NameNotFoundException: StoreAccessBean not bound at org.jnp.server.NamingServer.getBinding(NamingServe r.java:495) at org.jnp.server.NamingServer.getBinding(NamingServe ...

34. File access problem in Jboss ?    java-forums.org

35. jboss 6 persistence    java-forums.org

Hello, i tried to setup a database using jboss as 6 admin console to create the datasource and eclpise helios for enterprise application and JPA project. Folowing the tutorials i found everything should work but i get an error this is my IBMdb2-ds: Java Code: IBMdb2 jboss-local-jdbc.rar true javax.sql.DataSource jboss:service=invoker,type=unified 0 10 30000 30 false ...

36. JBoss devloy problem - urgent~!!!!!!!!    forums.oracle.com

I checked jmx-console, Inside Global JNDI Namespace, I can't see my project binded under. But initially there was no problem for deploying at all. Those session beans for entity class were all in. And the same codes are running perfectly in other PC, there is no such error. For Netbeans, the deployment is such a simple, but i dont know why ...

37. jboss    forums.oracle.com

38. JAVA in JBOSS    forums.oracle.com

/** * @hibernate.id * generator-class="native" * column="ID" */ public int getId() { return id; } public void setId(int id) { this.id = id; } /** * @hibernate.property * column="GROUP_NAME" */ public String getGroupName() { return groupName; } public void setGroupName(String groupName) { this.groupName = groupName; } /** * @hibernate.property * column="STATUS" */ public String getStatus() { return status; } public void ...

39. Jboss not getting up    forums.oracle.com

Hi, I am trying to run an application using jboss. i am using joss version 6 and java version 6. while making the server up i am getting the following error. getting the same result while double clicking run.bat as well as running run.bat through cmd. Please help me.... =============================================================================== JBoss Bootstrap Environment JBOSS_HOME: D:\jboss- JAVA: C:\Program Files\Java\jdk1.6.0\bin\java JAVA_OPTS: -Dprogram.name=run.bat -Xms128M ...

40. JBOSS downloading problem    forums.oracle.com

Hi when I was downloading JBOSS server, I found number of types of download and when I chose any one of them, then in it also I found number of type of files. I downloaded a file one of them but it has not setup file. so please tell me how can I download JBOSS server for EJB. Thanks

41. Issue with Code on JBoss 5 that worked on JBoss 4    forums.oracle.com

Perhaps you are trying to solve a problem that is not there? You state that your code works fine on JBoss 4.2.3 but not on JBoss 5.1. okay! I believe you! But the fact of the matter is that there is a big difference between JBoss 4.2.3 and JBoss 5.1: JBoss 5 is JEE5 compliant, while JBoss 4.2.3 is not. So ...

42. Java mail in jboss    forums.oracle.com

I have written an email gateway that uses pop3 to listen to inbox and receives new emails .I have deployed my ear on jboss server... is there any method to call the function once automatically when ear is deployed. any help would be appreciated regards Edited by: bhavna84 on Aug 25, 2008 11:38 PM

44. JBoss specification    forums.oracle.com

45. how to make Jboss Alive in Solaris    forums.oracle.com

46. Entity Beans deployed on JBOSS    forums.oracle.com

We have a Web application in our project that includes 6 Entity Beans with CMP fields1.1 The application was developed in WSAD 5.1 The WSAD generates Access Beans for each Entity Bean as well as stubs in default package com.ibm.ejs.container and com.ibm.websphere.csi. E.g. The Entity Bean Organization.java has Access Bean OrganizationAccessBean.java. Similarly for other 5 Entity Beans there are Access Beans ...

47. question based on JBoss    forums.oracle.com

I am using JBoss4.2.05_GA application server to deploy my web application and my machine is Linux, and I am using NetBeans IDE 5.5, I have configured JBoss to netBeans IDE and i start the server, the server is running fine. all the instructions regarding to JBoss are diplayed in the output window ok But the question is, when the server is ...

48. JBoss    forums.oracle.com

2007-10-03 19:47:39,737 ERROR [org.apache.jk.common.MsgAjp] BAD packet signature 18245 2007-10-03 19:47:39,737 ERROR [org.apache.jk.common.ChannelSocket] Error, processing connection java.lang.IndexOutOfBoundsException at java.io.BufferedInputStream.read(BufferedInputStream.java:272) at org.apache.jk.common.ChannelSocket.read(ChannelSocket.java:601) at org.apache.jk.common.ChannelSocket.receive(ChannelSocket.java:557) at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:666) at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:871) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684) at java.lang.Thread.run(Thread.java:534) 2007-10-03 19:47:59,688 ERROR [org.apache.tomcat.util.net.PoolTcpEndpoint] Socket error caused by remote host / java.net.SocketException: Connection reset at java.net.SocketInputStream.read(SocketInputStream.java:168) at com.sun.net.ssl.internal.ssl.InputRecord.a(DashoA12275) at com.sun.net.ssl.internal.ssl.InputRecord.read(DashoA12275) at com.sun.net.ssl.internal.ssl.SSLSocketImpl.a(DashoA12275) at com.sun.net.ssl.internal.ssl.SSLSocketImpl.j(DashoA12275) at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(DashoA12275) at org.apache.tomcat.util.net.jsse.JSSESocketFactory.handshake(JSSESocketFactory.java:119) at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:520) at ...

49. Embedding JBoss Naming In My Own Java Application    forums.oracle.com

public class Server { /** * Logger for this class. */ private static final Logger logger = Logger.getLogger("miaJs.server.Server"); /** * Start the server. */ public void start() { logger.debug("Server ClassLoader: " + this.getClass().getClassLoader().getClass().getName()); try { logger.debug("Starting JBoss naming server..."); Main namingServer = new Main(); namingServer.start(); } catch (Throwable t) { logger.error("Error starting Java Job Scheduler: " + t.getMessage(), t); System.exit(1); } ...

50. JBoss basic question but unable to solve    forums.oracle.com

org.jboss.deployment.DeploymentException: url file:/C:/jboss-4.0.4.GA/jboss-4.0.4.GA/server/default/ tmp/deploy/common/services could not be opened, does it exist? at org.jboss.deployment.DeploymentInfo.(DeploymentInfo.java:211) at org.jboss.deployment.MainDeployer.parseManifestLibraries(MainDeployer.java:1119) at org.jboss.deployment.MainDeployer.init(MainDeployer.java:873) at org.jboss.deployment.MainDeployer.init(MainDeployer.java:881) at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:798) at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:771) at sun.reflect.GeneratedMethodAccessor55.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:585) at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155) at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94) at org.jboss.mx.interceptor.AbstractInterceptor.invoke(AbstractInterceptor.java:133) at org.jboss.mx.server.Invocation.invoke(Invocation.java:88) at org.jboss.mx.interceptor.ModelMBeanOperationInterceptor.invoke(ModelMBeanOperationInterceptor.ja va:142) at org.jboss.mx.server.Invocation.invoke(Invocation.java:88) at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264) at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659) at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210) at $Proxy8.deploy(Unknown Source) at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:421) at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:634) at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentSc anner.java:263) at ...

52. How to confire JBOSS    forums.oracle.com

53. JBoss    forums.oracle.com

54. is it possible to use jdbcappender with jboss's logger?    forums.oracle.com

Back in my days, when you were new to Java, you wrote all sorts of stupid console programs and crapplets to get the hang of it. Anyway, without seeing JBoss' logging framework, I'm gonna say "no, you can't" unless they've actually bothered to make it compatible with commons-logging (or was that log4j). However, you probably could write your own JDBCAppender for ...

55. JBoss isnt starting up    forums.oracle.com

seems to be setting up of the things will kill my time my JBoss isnt starting up ........ the precise error what it is showing is i have given belowCould not locate C:\j2sdk1.4.0_05\lib\tools.jar. Unexpected results may occur. Make sure that JAVA_HOME points to a JDK and not a JRE. =============================================================================== . JBoss Bootstrap Environment . JBOSS_HOME: C:\jboss-3.2.5\bin .. . JAVA: C:\j2sdk1.4.0_05\bin\java ...

57. about jboss    forums.oracle.com

Are you talking about instances? The default instance is.... the 'default' instance. Each instance simply opens up more services - the 'all' instance has, well, ALL of them. The 'default' instance has everything needed to be fully JEE5 compliant already, mostly you'll just want to use (a copy of) that instance. As for which services are available or not in a ...